Для картинок в ЕГЭ разрешение и глубина кодирования - это одно и то же.

Задание 7 по информатике к ЕГЭ из разных источников

Прогноз на основную волну 2026

Маша делает цветные фотографии на телефон, который сохраняет снимки с размером 3840×2160 пикселей и разрешением 20 бит. После сохранения снимков в памяти телефона Маша отправляет фотографию через мессенджер, который сжимает снимок до размера 1280x720 пикселей. При отправке 120 фотографий удалось сэкономить 2322000 Кбайт. Какое максимальное количество цветов может быть в сжатой картинке?

В ответе запишите целое число.

Решение:

Размер фото до сжатия 3840×2160*20=165888000 бит
Размер после сжатия (разрешение по условию не известно) 1280x720*i
165888000*120-1280x720*i*120=2322000*8*1024
19906560000-110592000*i=19021824000
110592000*i=19906560000-19021824000
110592000*i=884736000
i=884736000/110592000=8
k=2i=28=256 цветов

На питоне:

from math import *

for n2 in range(100000, 0, -1):
    pic1 = 3840*2160*20
    pic2 = 1280*720*ceil(log2(n2))
    if 120*(pic1-pic2)==2322000*8*1024:
        print(n2)
        break

Ответ: 256

Маша делает цветные фотографии на телефон, который сохраняет снимки с размером  3840 × 2160  пикселей и разрешением  17 бит. После сохранения снимков в памяти телефона Маша отправляет фотографию через мессенджер, который сжимает снимок до размера  1280 × 720 пикселей, каждый разрешением  5 бит. Какое количество Кбайт удастся сэкономить при отправке  120 фотографий? В ответе запишите целое число.

Решение:

Одна фотография занимает в исходном размере занимает:
3840· 2160  · 17  =  141 004 800 бит  =  17 625 600 байт  =  17212,5 Кбайт.
Одна фотография после сжатия занимает:
1280· 720  · 5  =  4 608 000 бит  =  576 000 байт  =  562,5 Кбайт.
Вычислим экономию трафика при передачи 120 фотографий:
(17212,5-562,5)*120=1998000 Кбайт
1998000 Кбайт трафика экономится таким образом при передаче 120 фотографий.
Ответ: 1998000

ЕГЭ 2026. Апробация. 14.05.2026

Виталий фотографирует интересные места и события с помощью цифровой камеры своего смартфона. Каждая фотография представляет собой растровое изображение размером \(1024 \times 768\) пикселей, при этом используется палитра из \(2^{30}\) цветов. В конце дня Виталий отправляет снимки друзьям с помощью приложения-мессенджера. Для экономии трафика приложение оцифровывает снимки повторно, используя размер \(800 \times 600\) пикселей и глубину цвета \(28\) бит. Сколько Кбайт трафика экономится при передаче \(100\) фотографий?

В ответе укажите целую часть полученного числа.

Решение:

...
Ответ:


ЕГЭ 2026. ЕГКР. 18.04.2026

Маша скачивает из Интернета альбом любимой музыкальной группы, оцифрованный в формате стерео с частотой дискретизации \(20000\) Гц и разрешением \(32\) бит без использования сжатия. В альбоме \(13\) треков общей длительностью \(35\) минут \(50\) секунд. Каков максимально возможный объём заголовка трека в Кбайт, если известно, что общий объём альбома не превышает \(339\) Мбайт? В ответе запишите целое число.

Решение:

...
Ответ:


ЕГЭ 2026. Досрочный экзамен. 07.04.2026

Голосовое сообщение продолжительностью \(3\) минуты \(10\) секунд было записано в формате стерео и оцифровано с глубиной кодирования \(16\) бит и частотой дискретизации \(12~000\) измерений в секунду. Сжатие данных не использовалось. Определите объём голосового сообщения в Кбайт. В ответе укажите только целую часть полученного числа.

Решение:

...
Ответ:


ЕГЭ 2026. Апробация. 04.03.2026

Для хранения сжатого произвольного растрового изображения размером \(192\) на \(960\) пикселей отведено \(90\) Кбайт памяти без учёта заголовка файла. При сжатии объём файла уменьшается на \(15 \, \%.\) Для кодирования цвета каждого пикселя используется одинаковое количество бит, коды пикселей записываются в файл один за другим без промежутков. Какое максимальное количество цветов можно использовать в изображении?

Решение:

...
Ответ:


ЕГЭ 2026. ЕГКР. 13.12.2025

Прибор автоматической фиксации нарушений правил дорожного движения делает цветные фотографии размером \(1024 \times 960\) пикселей, используя палитру из \(16~384\) цветов. Для передачи снимки группируются в пакеты по \(400\) штук. Определите размер одного пакета фотографий в Мбайт. В ответе запишите целую часть полученного числа.

Решение:

...
Ответ:


ЕГЭ 2026. Демо

Музыкальный фрагмент был записан в формате моно, оцифрован и сохранён в виде файла без сжатия данных. Размер полученного файла − \(35\) Мбайт. Затем тот же музыкальный фрагмент был записан повторно в формате стерео (двухканальная запись) с частотой дискретизации в \(3{,}5\) раза больше, чем в первый раз. Сжатие данных не производилось. Укажите размер файла в Мбайт, полученного при повторной записи. В ответе запишите только целое число, единицу измерения писать не нужно.

Решение:

...
Ответ:

ЕГЭ 2026. Демо-2

Виталий фотографирует интересные места и события цифровой камерой своего смартфона. Каждая фотография представляет собой растровое изображение размером \(1024 \times 768\) пикселей, при этом используется палитра из \(2^{30}\) цветов. В конце дня Виталий отправляет снимки друзьям с помощью приложения-мессенджера. Для экономии трафика приложение оцифровывает снимки повторно, используя размер \(800 \times 600\) пикселей и глубину цвета \(28\) бит. Сколько Кбайт трафика экономится при передаче \(100\) фотографий?

В ответе укажите целую часть полученного числа.

Решение:

...
Ответ:


ЕГЭ 2026. Статград. 14.04.2026

Виталий фотографирует интересные места и события с помощью своего смартфона. Каждая фотография представляет собой растровое изображение размером \(8000 \times 6000\) пикселей, при этом используется палитра из \(158~543\) цветов. В конце года Виталий решил отправить снимки друзьям с помощью электронной почты. Для экономии трафика снимки оцифровываются повторно, используя размер \(320 \times 240\) пикселей и глубину цвета \(7\) бит. Сколько Гбайт трафика экономится при передаче \(1~348~897\) фотографий без учёта заголовков? Сжатия данных не производилось.

В ответе укажите целую часть полученного числа.

Решение:

...
Ответ:


ЕГЭ 2026. Статград. 03.03.2026

Музыкальный фрагмент был записан в формате квадро (четырёхканальная запись), оцифрован и сохранён в виде файла. При сжатии сохранённого файла его объём составил \(80 \, \%\) от первоначальной записи. Тот же музыкальный фрагмент был записан повторно в формате стерео (двухканальная запись) и оцифрован с разрешением в \(2\) раза ниже и частотой дискретизации в \(8\) раз выше, чем в первый раз. При сжатии данного файла его объём составил \(10 \, \%\) от повторной записи. Во сколько раз один из полученных объёмов больше другого? В ответе запишите только число.

Решение:

...
Ответ:


ЕГЭ 2026. Статград. 27.01.2026

Прибор автоматической фиксации нарушений правил дорожного движения делает цветные фотографии размером \(1195\) на \(1024\) пикселей, используя палитру из \(1568\) цветов. Снимки сохраняются в памяти камеры, группируются в пакеты по 367 шт., затем передаются в центр обработки информации со скоростью передачи данных 17 094 834 бит/с. Сколько минут требуется для передачи одного полного пакета фотографий? В ответе запишите только целую часть полученного числа.

Решение:

...
Ответ:


ЕГЭ 2026. Статград. 16.12.2025

Прибор автоматической фиксации нарушений правил дорожного движения делает цветные фотографии размером \(1600 \times 900\) пикселей, при этом используется палитра из \(4096\) цветов. Все снимки группируются в пакеты по \(X\) (\(Х\) – натуральное число) штук и передаются по каналу связи. Известно, что время передачи одного такого пакета занимает ровно \(3{,}5\) часа, а пропускная способность канала равна \(22406400\) бит/c. Определите, чему равно значение \(X.\) В ответе запишите только число.

Решение:

...
Ответ:


ЕГЭ 2026. Крылов. Вариант 20

Для хранения растрового изображения размером \(112 \times 240\) пикселей отведено не более \(36\) Кбайт памяти без учёта размера заголовка файла. Для кодирования цвета каждого пикселя используется одинаковое количество бит, коды пикселей записываются в файл один за другим без промежутков. Какое максимальное количество цветов можно использовать в палитре изображения?

Решение:

...
Ответ:

ЕГЭ 2026. Крылов. Вариант 19

Для хранения растрового изображения размером \(90 \times 1024\) пикселей отведено не более \(80\) Кбайт памяти без учёта размера заголовка файла. Для кодирования цвета каждого пикселя используется одинаковое количество бит, коды пикселей записываются в файл один за другим без промежутков. Какое максимальное количество цветов можно использовать в палитре изображения?

Решение:

...
Ответ:


ЕГЭ 2026. Крылов. Вариант 18

Для хранения растрового изображения размером \(70 \times 256\) пикселей отведено не более \(10\) Кбайт памяти без учёта размера заголовка файла. Для кодирования цвета каждого пикселя используется одинаковое количество бит, коды пикселей записываются в файл один за другим без промежутков. Какое максимальное количество цветов можно использовать в палитре изображения?

Решение:

...
Ответ:


ЕГЭ 2026. Крылов. Вариант 17

Для хранения растрового изображения размером \(360 \times 512\) пикселей отведено не более \(240\) Кбайт памяти без учёта размера заголовка файла. Для кодирования цвета каждого пикселя используется одинаковое количество бит, коды пикселей записываются в файл один за другим без промежутков. Какое максимальное количество цветов можно использовать в палитре изображения?

Решение:

...
Ответ:


ЕГЭ 2026. Крылов. Вариант 16

Музыкальный фрагмент был записан в формате стерео (двухканальная запись), оцифрован и сохранён в виде файла без использования сжатия данных. Размер полученного файла — \(39\) Мбайт. Затем тот же музыкальный фрагмент был записан повторно в формате моно и оцифрован с расширением в \(2{,}5\) раза выше и частотой дискретизации в \(4\) раза больше, чем в первый раз. Сжатие данных не проводилось. Укажите размер файла в Мбайтах, полученных при повторной записи. В ответе укажите только целое число, единицу измерений писать не нужно.

Решение:

...
Ответ:


ЕГЭ 2026. Крылов. Вариант 15

Музыкальный фрагмент был записан в формате моно, оцифрован и сохранён в виде файла без использования сжатия данных. Размер полученного файла — \(56\) Мбайт. Затем тот же музыкальный фрагмент был записан повторно в формате стерео (двухканальная запись) и оцифрован с расширением в \(4{,}5\) раза выше и частотой дискретизации в \(3\) раза меньше, чем в первый раз. Сжатие данных не проводилось. Укажите размер файла в Мбайтах, полученных при повторной записи. В ответе укажите только целое число, единицу измерений писать не нужно.

Решение:

...
Ответ:


ЕГЭ 2026. Крылов. Вариант 14

Для хранения сжатого произвольного растрового изображения размером \(1024 \times 100\) пикселей отведено \(75\) Кбайт памяти без учёта размера заголовка файла. Файл оригинального изображения больше сжатого на \(35 \, \% .\) Для кодирования цвета каждого пикселя используется одинаковое количество бит, коды пикселей записываются в файл один за другим без промежутков. Какое максимальное количество цветов можно использовать в изображении?

Решение:

...
Ответ:

ЕГЭ 2026. Крылов. Вариант 13

Для хранения сжатого произвольного растрового изображения размером \(512 \times 750\) пикселей отведено \(80\) Кбайт памяти без учёта размера заголовка файла. Файл оригинального изображения больше сжатого на \(65 \, \% .\) Для кодирования цвета каждого пикселя используется одинаковое количество бит, коды пикселей записываются в файл один за другим без промежутков. Какое максимальное количество цветов можно использовать в изображении?

Решение:

...
Ответ:


ЕГЭ 2026. Крылов. Вариант 12

Сколько секунд потребуется обычному модему, передающему сообщения со скоростью \(14~400\) бит/с, чтобы передать музыкальный фрагмент, записанный в формате квадро (четырёхканальная запись) с частотой дискретизации \(96\) кГц и \(24\)-битным разрешением длительностью \(7\) секунд?

Решение:

...
Ответ:


ЕГЭ 2026. Крылов. Вариант 11

Сколько секунд потребуется обычному модему, передающему сообщения со скоростью \(28~800\) бит/с, чтобы передать музыкальный фрагмент, записанный в формате стерео (двухканальная запись) с частотой дискретизации \(96\) кГц и \(24\)-битным разрешением длительностью \(10\) секунд?

Решение:

...
Ответ:


ЕГЭ 2026. Крылов. Вариант 10

Сколько секунд потребуется обычному модему, передающему сообщения со скоростью \(33~600\) бит/с, чтобы передать цветное растровое изображение размером \(240 \times 1890\) пикселей, при условии, что цвет каждого пикселя кодируется \(8\) байтами?

Решение:

...
Ответ:


ЕГЭ 2026. Крылов. Вариант 9

Сколько секунд потребуется обычному модему, передающему сообщения со скоростью \(14~400\) бит/с, чтобы передать цветное растровое изображение размером \(480 \times 270\) пикселей, при условии, что цвет каждого пикселя кодируется \(4\) байтами?

Решение:

...
Ответ:


ЕГЭ 2026. Крылов. Вариант 8

Автоматическая ловушка в заповеднике, оснащённая датчиком движения, делает цветные фотографии проходящих мимо леопардов. Размер каждой фотографии \(1024 \times 64\) пикселей, при этом используется палитра из \(4096\) цветов. Снимки сохраняются в память камеры, группируются в пакеты по несколько штук, а затем передаются в центр охраны природы со скоростью передачи данных \(655~360\) бит/с. Каково максимально возможное количество снимков в одном пакете, если на передачу одного пакета отводится не более \(70\) секунд?

Решение:

...
Ответ:

ЕГЭ 2026. Крылов. Вариант 7

Автоматическая ловушка в заповеднике, оснащённая датчиком движения, делает цветные фотографии проходящих мимо леопардов. Размер каждой фотографии \(128 \times 2048\) пикселей, при этом используется палитра из \(2048\) цветов. Снимки сохраняются в память камеры, группируются в пакеты по несколько штук, а затем передаются в центр охраны природы со скоростью передачи данных \(81~920\) бит/с. Каково максимально возможное количество снимков в одном пакете, если на передачу одного пакета отводится не более \(600\) секунд?

Решение:

...
Ответ:


ЕГЭ 2026. Крылов. Вариант 6

Автоматическая ловушка в заповеднике, оснащённая датчиком движения, делает цветные фотографии проходящих мимо леопардов. Размер каждой фотографии \(256 \times 2560\) пикселей, при этом используется палитра из \(256\) цветов. Снимки сохраняются в память камеры, группируются в пакеты по несколько штук, а затем передаются в центр охраны природы со скоростью передачи данных \(163~840\) бит/с. Каково максимально возможное количество снимков в одном пакете, если на передачу одного пакета отводится не более \(250\) секунд?

Решение:

...
Ответ:


ЕГЭ 2026. Крылов. Вариант 5

Автоматическая ловушка в заповеднике, оснащённая датчиком движения, делает цветные фотографии проходящих мимо леопардов. Размер каждой фотографии \(768 \times 5120\) пикселей, при этом используется палитра из \(256\) цветов. Снимки сохраняются в память камеры, группируются в пакеты по несколько штук, а затем передаются в центр охраны природы со скоростью передачи данных \(665~360\) бит/с. Каково максимально возможное количество снимков в одном пакете, если на передачу одного пакета отводится не более \(500\) секунд?

Решение:

...
Ответ:


ЕГЭ 2026. Крылов. Вариант 4

Путешественник фотографирует достопримечательности с помощью камеры смартфона Каждая фотография представляет собой растровое изображение размером \(1920 \times 1600\) пикселей, при этом используется палитра из \(2^{30}\) цветов. В конце дня путешественник отправляет снимки родственникам с помощью приложения-мессенджера. Для экономии трафика приложение оцифровывает снимки повторно, используя размер \(800 \times 400\) пикселей и глубину цвета \(24\) бит. Сколько Кбайт трафика экономится при передаче \(90\) фотографий?

В ответе укажите целую часть полученного числа.

Решение:

...
Ответ:


ЕГЭ 2026. Крылов. Вариант 3

Путешественник фотографирует достопримечательности с помощью камеры смартфона Каждая фотография представляет собой растровое изображение размером \(2048 \times 1000\) пикселей, при этом используется палитра из \(2^{28}\) цветов. В конце дня путешественник отправляет снимки родственникам с помощью приложения-мессенджера. Для экономии трафика приложение оцифровывает снимки повторно, используя размер \(1920 \times 512\) пикселей и глубину цвета \(16\) бит. Сколько Кбайт трафика экономится при передаче \(30\) фотографий?

В ответе укажите целую часть полученного числа.

Решение:

...
Ответ:


ЕГЭ 2026. Крылов. Вариант 2

Путешественник фотографирует достопримечательности с помощью камеры смартфона Каждая фотография представляет собой растровое изображение размером \(3200 \times 1600\) пикселей, при этом используется палитра из \(2^{24}\) цветов. В конце дня путешественник отправляет снимки родственникам с помощью приложения-мессенджера. Для экономии трафика приложение оцифровывает снимки повторно, используя размер \(1200 \times 800\) пикселей и глубину цвета \(8\) бит. Сколько Кбайт трафика экономится при передаче \(50\) фотографий?

В ответе укажите целую часть полученного числа.

Решение:

...
Ответ: