Правило суммы Правило произведения
Если события
НЕ зависят друг от друга зависят друг от друга
то количество способов выполнить
 ИЛИ первое, ИЛИ второе, …, ИЛИ n-ое событие  И первое, И второе, …, И n-ое событие 
будет равно
сумме произведению 
способов их выполнения

Подсказки для прототипа на составление чисел и слов:

Условие

Как влияет?

«Буква / цифра в слове встречается ровно один раз»

Рассматриваем столько случаев, сколько длина слова / числа

«Каждая из других допустимых букв может встречаться в слове не более одного раза»   или  «Все цифры различны»

С каждой следующей позицией количество вариантов уменьшается на 1.   Важно: не забывать, про буквы / числа, которые «стали снова доступны» («на первом месте не может быть буква Н»)

Ноль – особое число

Ноль – чётный   С нуля числа не начинаются!

«Никакие две чётные и две нечётные цифры не стоят рядом»  Чётные и нечётные цифры чередуются.   Рассматривается 2 случая  

Алгоритм решения прототипа задания №8 со списком слов:

1. Основание «системы счисления» равно числу различных букв  
2. По порядку крайних первых букв в списке «слов» сопоставлять каждую букву с цифрой (первая –0, 
 вторая –1 и т. д.)  
3. Если надо найти слово по положению – из порядкового номера вычитаем 1, переводим в выбранную СС 
 и переписываем в буквенном обозначении  
4. Если необходимо найти положение «слова» в списке – переписываем его в выбранной СС, переводим в десятичную и прибавляем 1.  

Пример программного решения прототипа на составление слов и чисел 

Сколько существует восьмеричных пятизначных чисел, не содержащих в своей записи цифру 1, в которых все цифры различны и никакие две чётные или две нечётные цифры не стоят рядом? 

from itertools import product
k = 0  

for x in product('0234567', repeat=5):
  
 if x[0] != '0' and len(set(x)) == len(x):
  
       f = True  

      
   for i in range(len(x) - 1):
  
             if int(x[i]) % 2 == int(x[i+1]) % 2:
  
                 f = False
  
       if f: 
 
             k += 1
print(k)

Пример программного решения прототипа со списком слов

Все шестибуквенные слова, составленные из букв М, А, Н, Г, У, С, Т, записаны в алфавитном порядке и пронумерованы.    Вот начало списка:

1.  АААААА   
2.  АААААГ   
3.  АААААМ   
4.  АААААН   
5.  АААААС   
6.  АААААТ   
7.  АААААУ   
8. ААААГА   
……  

Под каким номером в списке стоит последнее слово, которое не начинается с буквы У, содержит только две буквы М и не более одной буквы Г?

from itertools import product   # достаем функцию из библиотеки
number = 0  # переменная для номера слова  
# перебираем комбинации из букв слова МАНГУСТ в алфавитном порядке

for x in product('АГМНСТУ', repeat=6): 
      number += 1      # увеличиваем номер слова  
# проверяем условие задания

      if x[0] != 'У' and x.count('М') == 2 and x.count('Г') <= 1: 
      print(number)      # выводим номер подходящего слова

Прототипы с ЕГЭ

Задача №1 Все 4-буквенные слова, составленные из букв Д, Е, К, О, Р, записаны в алфавитном порядке и пронумерованы, начиная с 1. Ниже приведено начало списка.
1. ДДДД
2. ДДДЕ
3. ДДДК
4. ДДДО
5. ДДДР
6. ДДЕД

Под каким номером в списке идёт первое слово, которое начинается с буквы K?

Ответ: 251

Задача №2 Игорь составляет таблицу кодовых слов для передачи сообщений, каждому сообщению соответствует своё кодовое слово. В качестве кодовых слов Игорь использует трёхбуквенные слова, в которых могут быть только буквы Ш, К, О, Л, А, причём буква К появляется ровно 1 раз. Каждая из других допустимых букв может встречаться в кодовом слове любое количество раз или не встречаться совсем. Сколько различных кодовых слов может использовать Игорь?

Ответ: 48

Задача №3 Определите количество пятизначных чисел в шестнадцатеричной системе счисления, которые не оканчиваются чётными цифрами и не начинаются с цифры 1.

Ответ: 458752

Задача №4 Определите количество семизначных чисел, записанных в семеричной системе счисления, учитывая, что числа не могут начинаться с цифр 3 и 5 и не должны содержать сочетания цифр 22 и 44 одновременно.

Ответ: 466456

Задача №5 Все пятибуквенные слова, составленные из букв К, О, М, П, Ь, Ю, Т, Е, Р, записаны в алфавитном порядке и пронумерованы. Вот начало списка:
1. ЕЕЕЕЕ
2. ЕЕЕЕК
3. ЕЕЕЕМ
4. ЕЕЕЕО
5. ЕЕЕЕП
6. ЕЕЕЕР
7. ЕЕЕЕТ
8. ЕЕЕЕЬ
Под каким номером в списке стоит последнее слово с нечётным номером, которое не начинается с буквы Ь и содержит ровно две буквы К?

Ответ: 58979

Задания уровня ЕГЭ

Задача №1 Катя составляет 5-буквенные слова из букв слова АПРЕЛЬ и упорядочивает их в обратном алфавитном порядке. Вот начало списка:
1. ЬЬЬЬЬ
2. ЬЬЬЬР
3. ЬЬЬЬП
4. ЬЬЬЬЛ
5. ЬЬЬЬЕ
6. ЬЬЬЬА
7. ЬЬЬРЬ
Сколько слов, оканчивающихся на Ь, запишет Катя, если заполнит список до 387 позиции (включительно)?

Ответ: 65

Задача №2 Петя составляет четырехбуквенные слова из символов КЕГЭ2023 и записывает их в алфавитном порядке в список. Вот начало списка
1. ГГГГ
2. ГГГЕ
3. ГГГК
4. ГГГЭ
5. ГГГ0
6. ГГГ2
7. ГГГ3
8. ГГЕГ
На какой позиции будет стоять первое слово, начинающееся с цифры, и не содержащее двух подряд идущих одинаковых символов?

Ответ: 1380

Задача №3 Сколько существует способов разместить на книжной полке шесть книг, среди которых имеются четыре тома романа «Война и мир», которые должны стоять рядом (но не обязательно по порядку)?

Ответ: 144

Задача №4 (5438) Оля составляет слова перестановкой букв слова СПОРТЛОТО. Отбросив одинаковые слова и слова начинающиеся и заканчивающиеся гласной Оля отсортировала их и пронумеровала начиная с 1. Под каким номером находится последнее слово?

Ответ: 126