Алгоритм разложения числа на цифры

x =        # искомое число
while x > 0:
    d = x % <система счисления>  # получаем последнюю цифру числа
    …        # анализируем полученную цифру
    x = x // <система счисления>   # убираем из числа последнюю цифру

Алгоритм решения задания №14 для прототипа со степенями

  1. Вычисление значения выражения
  2. Подсчет количества цифр, используя алгоритм разложения числа на разряды.

Алгоритм решения задания №14 с неизвестной цифрой в n-ричной системе счисления

for x in'<цифры нужной СС>':  # перебор всех цифр в СС

     # перевод компонентов выражения в десятичную СС
      a = int('<первое число в выражении>', <основание СС>)
      b = int('<второе число в выражении>', <основание СС>)
      res = <результат арифметического выражения>
      # проверка условия из задания
      if res % <число из условия> == 0:
         print(res // <число из условия>)   # вывод частного

Прототипы с ЕГЭ

Задача №1 Значение арифметического выражения
5 · 2163031 + 4 · 363042 - 3 · 63053 - 3064
записали в системе счисления с основанием 6. Определите сумму цифр в записи этого числа.

Ответ: 30417

Задача №2 Операнды арифметического выражения записаны в системе счисления с основанием 15.
97968x1315 + 7x21315
В записи чисел переменной x обозначена неизвестная цифра из алфавита 15-ричной системы счисления. Определите наименьшее значение x, при котором значение данного арифметического выражения кратно 14. Для найденного значения x вычислите частное от деления значения арифметического выражения на 14 и укажите его в ответе в десятичной системе счисления. Основание системы счисления в ответе указывать не нужно.

Ответ: 116070624

Задачи уровня ЕГЭ

Задача №1 Решите уравнение 10xyx6 = y11x7, где x и y – неизвестные разряды. В ответе укажите сумму найденных значений переменных.

Ответ: 7

Задача №2 Значение арифметического выражения: 3⋅7x+1 + 13⋅7x+2 + 31⋅73x + 1⋅72x записали в системе счисления с основанием 7. Известно, что сумма разрядов в получившемся числе равна 18. Укажите минимальное значение переменной x, при котором это возможно.

Ответ: 3

Задача №3 Значение арифметического выражения: X = 7103 + 4998 – 7120 – 733 записали в системе счисления с основанием 7. Определите минимальное количество значащих разрядов в семеричной записи положительного числа Y, таком, что сумма цифр числа X + Y, записанного в системе счисления с основанием 7, будет минимальной.

Ответ: 120

Задача №4 В системе счисления с основанием p выполняется равенство xxx8 + 43x9 = yy04. Буквами x и y обозначены некоторые цифры из алфавита системы счисления с основанием p. Определите значение числа yyxp и запишите это значение в десятичной системе счисления.

Ответ: 1826