Рекурсивные функции с возвращаемыми значениями

Алгоритм вычисления значения функции F(n), где n  — целое неотрицательное число, задан следующими соотношениями:

F(n) = 0, при n ≤ 1;

F(n) = F(n − 1) + 3n2, если n > 1 и при этом нечётно;

F(n) = n / 2 + F(n − 1) + 2, если n > 1 и при этом чётно.

Чему равно значение функции F(49)? В ответе запишите только целое число.

def F(n):
    if n <= 1:
        return 0
    if n % 2 == 1:
        return F(n-1) + 3*n*n
    return n // 2 + F(n-1) + 2
print(F(49))

Алгоритмы, опирающиеся на несколько предыдущих значений

Последовательность чисел трибоначчи задается рекуррентным соотношением:

F(1) = 0
F(2) = 1
F(3) = 1
F(n) = F(n–3) + F(n–2) + F(n–1), при n >3, где n – натуральное число.

Чему равно девятое число в последовательности трибоначчи?

def F(n):
    if n == 1:
        return 1
    if n == 2:
        return 1
    if n > 2:
        return F(n-2) + F(n-1)
print(F(9))

Алгоритм вычисления значения функции F(n), где n  — целое неотрицательное число, задан следующими соотношениями: F(0) = 0;

   F(n) = F(n − 1) + 1, если n нечётно;

              F(n) = F(n / 2), если n > 0 и при этом n чётно.

 Укажите количество таких значений n < 1 000 000 000, для которых F(n)  =  3.

    3 =   30!   = 4060
С 30   3!*27!

3.      Алгоритмы, опирающиеся на одно предыдущее значение

Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями:

F(1) = 1

F(n) = F(n–1) * n, при n >1

Чему равно значение функции F(5)? В ответе запишите только натуральное число.

def F(n):
    if n == 1:
       return 1
    if n > 1:
       return F(n-1) * n
print(F(5))

Прототипы с ЕГЭ

Задача №1 Алгоритм вычисления функции F(n), где n – натуральное число, задан следующими соотношениями:
F(n)=1, если n=1
F(n)=F(n−1)⋅(2n−3), если n>1.
Чему равно значение выражения F(516)/F(513)?

Ответ: 1083202575

Задача №2 Алгоритм вычисления значения функции F(n), где n — натуральное число, задан следующими соотношениями:
F(n)=2 при n<3;
F(n)=F(n−2)−F(n−1)+2, если n>2 и при этом n чётно;
F(n)=F(n−1)−F(n−2)−2, если n>2 и при этом n нечётно;
Чему равно значение функции F(29)?

Ответ: 1510

Задача №3 Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями:
F(n)=n , если n≥2025,
F(n)=n+3+F(n+3), если n<2025.
Чему равно значение выражения F(23)−F(21)?

Ответ: 1338

Задача №4 Ниже на пяти языках программирования записан рекурсивный алгоритм F.

Чему равна сумма напечатанных на экране чисел при выполнении вызова F(10)?

Ответ: 33

Задания уровня ЕГЭ

Задача №1 Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями:
F(n)=7 при n<7;
F(n)=5−F(n−1), если n≥7 и значение n не кратно 3;
F(n)=3+F(n−1), если n≥7 и значение n кратно 3.
Чему равно значение выражения F(3015)?

Ответ: 3016

Задача №2 Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями:
F(n)=n , если n≥2222,
F(n)=F(n+5)+7, если n<2222.
Чему равно значение выражения F(45)−F(49)?

Ответ: 8

Задача №3 Алгоритм вычисления функции F(n) задан следующими соотношениями:
F(n)=1 при n<−100000
F(n)=F(n−1)+3⋅F(n−3)+2 при n>10
F(n)=−F(n−1) для остальных случаев.
Чему равно значение функции F(20)?

Ответ: 136

Задача №4 Алгоритм вычисления функций F(n), где n – натуральное число, задан следующими соотношениями:
F(n)=n−1 при n<4
F(n)=n+2⋅F(n−1) когда n>3 и кратно 3
F(n)=F(n−2)+F(n−3) когда n>3 и не кратно 3.
Чему равна сумма цифр значения функции F(25)?

Ответ: 13

Задача №5 Алгоритм вычисления функции F(n) задан следующими соотношениями:
F(n)=5 при n=0
F(n)=3⋅F(n−4) если n положительное
F(n)=F(n+3) если n отрицательное.
Чему равно значение функции F(43)?

Ответ: 7971615