Четырнадцатая линейка ЕГЭ по информатике на знание систем счисления, перевод из одной в другую. Задания в банке ФИПИ простые, но на реальных ЕГЭ в последнее время гораздо сложнее (смотрите в тренажере>>).

КЭС 2.1 Двоичное кодирование. Равномерные и неравномерные коды. Декодирование сообщений, записанных с помощью неравномерных кодов. Условие Фано. Построение однозначно декодируемых кодов с помощью дерева
2.2 Теоретические подходы к оценке количества информации. Единицы измерения количества информации. Алфавитный подход к оценке количества информации. Закон аддитивности информации. Формула Хартли. Информация и вероятность. Формула Шеннона
2.5 Кодирование текстов. Кодировка ASCII. Однобайтные кодировки. Стандарт UNICODE. Кодировка UTF-8. Определение информационного объёма текстовых сообщений
2.6 Кодирование изображений. Оценка информационного объёма графических данных при заданных разрешении и глубине кодирования цвета. Цветовые модели. Кодирование звука. Оценка информационного объёма звуковых данных при заданных частоте дискретизации и разрядности кодирования

Для перевода из любой (на примере - восьмеричной) в десятичную
int('nomber', 8)

Из десятичной в двоичную
bin(nomber)
  в восьмеричную
oct(nomber)
  в 16-ричную
hex(nomber)

Из десятичной в любую (на примере в третичную):
n = 343**6-7**10+47
string = ''
while n >0:
    string += str(n%3)
    n//= 3
print(string[::-1])

Задания 14 ЕГЭ по информатике из банка ФИПИ

Впишите правильный ответ.
Вычислите значение выражения 9E16 – 9216.

В ответе запишите вычисленное значение в десятичной системе счисления.

Решение:

Алфавит 0123456789ABCDEF, где A = 10, B = 11, ... F = 15.
9E16 = 9 × 161 + E × 160= 144 + 14= 15810
9216 = 9 × 161 + 2 × 160= 144 + 2= 14610
158+146=12

Ответ: 12

Pyhton

# Запрашиваем у пользователя ввод значений в шестнадцатеричной системе
x_hex = input("Введите первое число: ")
y_hex = input("Введите второе число: ")
# Преобразуем значения из шестнадцатеричной системы в десятичную
x_decimal = int(x_hex, 16)
y_decimal = int(y_hex, 16)
# Вычисляем разность
result = x_decimal - y_decimal
# Выводим результат в десятичной системе
print(f"Результат в десятичной системе: {result}")

Или сразу с числами считаем прямо в питоновской консоли. В Python перевести число странной системы счисления в десятичное можно с помощью функции int(), которая принимает два аргумента: строку самого числа и основание системы счисления (16 для шестнадцатеричной, 8 для восьмеричной и так далее). Одна строка и результат готов.

int('9E', 16) - int('92', 16)

Номер: 300EF5

Впишите правильный ответ.
Сколько единиц в двоичной записи шестнадцатеричного числа E1F016?

Решение:

Если считать ручками, сначала переведем число в десятичную систему, а потом в двоичную. Сделать это легко в питонячей консоли.

Переводим в десятичную через int и основание системы счисления
int('E1F0', 16)

получаем
57840

Переводим в двоичную через bin
bin(57840)

получаем
'0b1110000111110000'

0b - это префикс бинарной системы, его можно убрать, добавив после bin(57840) [2:]

считаем единицы
str(1110000111110000).count('1')

их 8 штук.
Ответ: 8

Программно:

# Функция для подсчета единиц и нулей в двоичной записи
def count_ones_and_zeros(hex_number):
    # Преобразуем шестнадцатеричное число в десятичное
    decimal_number = int(hex_number, 16)

    # Преобразуем десятичное число в двоичное
    binary_representation = bin(decimal_number)[2:] # Убираем префикс '0b'

    # Считаем количество единиц и нулей
    count_ones = binary_representation.count('1')
    count_zeros = binary_representation.count('0')

    return count_ones, count_zeros

# Запрашиваем у пользователя ввод шестнадцатеричного числа
hex_input = input("Введите шестнадцатеричное число: ")

# Получаем количество единиц и нулей
ones, zeros = count_ones_and_zeros(hex_input)

# Выводим результат
print(f"В двоичной записи числа {hex_input} количество единиц: {ones}, количество нулей: {zeros}")

Номер: 714207

Впишите правильный ответ.
Сколько существует натуральных чисел x, для которых выполняется неравенство 100110112 < x < 100111112?

В ответе укажите только количество чисел, сами числа писать не нужно.

Решение:

Сначала из бинарной переведем в десятичную
int('10011011', 2)
int('10011111', 2)

Получим неравенство 155 < x < 159, тут х может быть только 156, 157 или 158 - 3 варианта.
Ответ: 3

Но может быть и бОльшая разница в числах, и тогда лучше решать программно.
Образец решения прототипа на питоне в номере 84C1E2

Коротко можно решить так:

x_min = int('10011011', 2)   # 155
x_max = int('10011111', 2)  # 159
count = x_max - x_min - 1   # 159 - 155 - 1 = 3
print(count)

Номер: B44A04

Впишите правильный ответ.
Сколько существует натуральных чисел x, для которых выполняется неравенство D716 < x < DF16?

В ответе укажите только количество чисел, сами числа писать не нужно.

Решение:

Образец решения на питоне в номере 84C1E2
Ответ: 7

x_min = int('D7', 16) 
x_max = int('DF', 16) 
print(x_max - x_min - 1)

Или вовсе в консоли вводим
int('DF', 16)-int('D7', 16)-1

только местами не перепутайте

Номер: 9EE305

Впишите правильный ответ.
Сколько существует натуральных чисел x, для которых выполняется неравенство 101101112 < x < 101111112?

В ответе укажите только количество чисел, сами числа писать не нужно.

Решение:

Образец решения на пайтон в номере 84C1E2
Ответ: 7

Номер: 533671

Впишите правильный ответ.
Вычислите значение выражения 9E16 – 9916.

В ответе запишите вычисленное значение в десятичной системе счисления.

Решение:

Решение на пайтоне в номере 300EF5
Ответ: 5

Номер: E59C76

Впишите правильный ответ.
Вычислите значение выражения 9C16 – 9416.

В ответе запишите вычисленное значение в десятичной системе счисления.

Решение:

Решение на пайтоне в номере 300EF5
Ответ: 8

Номер: 39F67C

Впишите правильный ответ.
Вычислите значение выражения 9E16 – 9416.

В ответе запишите вычисленное значение в десятичной системе счисления.

Решение:

Решение на пайтоне в номере 300EF5
Ответ: 10

Номер: 2E93BC

Впишите правильный ответ.
Вычислите значение выражения 9F16 –9216.

В ответе запишите вычисленное значение в десятичной системе счисления.

Решение:

Решение на пайтоне в номере 300EF5
9F16 = 15910
9216 = 14610
159-146=13
Ответ: 13

Номер: 6DED13

Впишите правильный ответ.
Вычислите значение выражения 9E16 – 9616.

В ответе запишите вычисленное значение в десятичной системе счисления.

Решение:

Решение на пайтоне в номере 300EF5
9E16 = 15810
9616 = 15010
158-150=8
Ответ: 8

Номер: 33AB2D

Впишите правильный ответ.
Сколько существует натуральных чисел x, для которых выполняется неравенство AB16 < x < AF16?

В ответе укажите только количество чисел, сами числа писать не нужно.

Решение:

Образец решения на пайтон в номере 84C1E2
AB16 = (10 × 161) + (11 × 160) = 160 + 11 = 17110
AF16 = (10 × 161) + (15 × 160) = 160 + 15 = 17510
172,173,174 - 3 числа
Ответ: 3

Номер: 8E552F

Впишите правильный ответ.
Вычислите значение выражения 7E16 – 7A16.

В ответе запишите вычисленное значение в десятичной системе счисления.

Решение:

Решение на пайтоне в номере 300EF5
7E16 = (7 × 161) + (14 × 160) = 112 + 14 = 12610
7A16 = (7 × 161) + (10 × 160) = 112 + 10 = 12210
126-122=4
Ответ: 4

Номер: 6E8DD6

Впишите правильный ответ.
Сколько существует натуральных чисел x, для которых выполняется неравенство B716 < x < BF16?

В ответе укажите только количество чисел, сами числа писать не нужно.

Решение:

Образец решения на пайтон в номере 84C1E2
B716 = (11 × 161) + (7 × 160) = 176 + 7 = 18310
BF16 = (11 × 161) + (15 × 160) = 176 + 15 = 19110
191-183-1=7
Ответ: 7

Номер: 4EA553

Впишите правильный ответ.
Сколько существует натуральных чисел x, для которых выполняется неравенство 101111012 < x < 101111112?

В ответе укажите только количество чисел, сами числа писать не нужно.

Решение:

Образец решения на пайтон в номере 84C1E2
101111012 = (1 × 27) + (0 × 26) + (1 × 25) + (1 × 24) + (1 × 23) + (1 × 22) + (0 × 21) + (1 × 20) = 128 + 0 + 32 + 16 + 8 + 4 + 0 + 1 = 18910
101111112 = (1 × 27) + (0 × 26) + (1 × 25) + (1 × 24) + (1 × 23) + (1 × 22) + (1 × 21) + (1 × 20) = 128 + 0 + 32 + 16 + 8 + 4 + 2 + 1 = 19110
Ответ: 1

Номер: E42756

Впишите правильный ответ.
Вычислите значение выражения FE16 – F116.

В ответе запишите вычисленное значение в десятичной системе счисления.

Решение:

Решение на пайтоне в номере 300EF5
FE16 = (15 × 161) + (14 × 160) = 240 + 14 = 25410
F116 = (15 × 161) + (1 × 160) = 240 + 1 = 24110
254-241=13
Ответ: 13

Номер: 5168A5

Впишите правильный ответ.
Сколько существует натуральных чисел x, для которых выполняется неравенство 9B16 < x < 9F16?

В ответе укажите только количество чисел, сами числа писать не нужно.

Решение:

Образец решения на пайтон в номере 84C1E2
9B16 = (9 × 161) + (11 × 160) = 144 + 11 = 15510
9F16 = (9 × 161) + (15 × 160) = 144 + 15 = 15910
159-155-1=3
Ответ: 3

Номер: C2A3AA

Впишите правильный ответ.
Сколько единиц в двоичной записи шестнадцатеричного числа E0F316?

Решение:

Образец программы на пайтоне, считающей нули и единицы, в номере 714207
E0F316 = (14 × 163) + (0 × 162) + (15 × 161) + (3 × 160) = 57344 + 0 + 240 + 3 = 5758710
5758710 = 11100000111100112
Ответ: 9

Номер: 6D57A0

Впишите правильный ответ.
Вычислите значение выражения 9F16 – 9616.

В ответе запишите вычисленное значение в десятичной системе счисления.

Решение:

Решение на пайтоне в номере 300EF5
9F16 = (9 × 161) + (15 × 160) = 144 + 15 = 15910
9616 = (9 × 161) + (6 × 160) = 144 + 6 = 15010
159-150=9
Ответ: 9

Номер: 644EA2

Впишите правильный ответ.
Сколько существует натуральных чисел x, для которых выполняется неравенство E716 < x < EF16?

В ответе укажите только количество чисел, сами числа писать не нужно.

Решение:

Образец решения на пайтон в номере 84C1E2
Ответ: 7

Номер: 0578C6

Впишите правильный ответ.
Сколько существует натуральных чисел x, для которых выполняется неравенство C716 < x < CF16?

В ответе укажите только количество чисел, сами числа писать не нужно.

Решение:

Образец решения на пайтон в номере 84C1E2
Ответ: 7

Номер: 47409C

Впишите правильный ответ.
Сколько существует натуральных чисел x, для которых выполняется неравенство F716 < x < FF16?

В ответе укажите только количество чисел, сами числа писать не нужно.

Решение:

Образец решения на пайтон в номере 84C1E2
Ответ: 7

Номер: F22A95

Впишите правильный ответ.
Вычислите значение выражения 8F16 – 8C16.

В ответе запишите вычисленное значение в десятичной системе счисления.

Решение:

Решение на пайтоне в номере 300EF5
Ответ: 3

Номер: D6129B

Впишите правильный ответ.
Сколько существует натуральных чисел x, для которых выполняется неравенство 8B16 < x < 8F16?

В ответе укажите только количество чисел, сами числа писать не нужно.

Решение:

Образец решения на пайтон в номере 84C1E2
Ответ: 3

Номер: C2FD97

Впишите правильный ответ.
Сколько существует натуральных чисел x, для которых выполняется неравенство A716 < x < AF16?

В ответе укажите только количество чисел, сами числа писать не нужно.

Решение:

Образец решения на пайтон в номере 84C1E2
Ответ: 7

Номер: 65B4E6

Впишите правильный ответ.
Вычислите значение выражения 9F16 – 9416.

В ответе запишите вычисленное значение в десятичной системе счисления.

Решение:

Решение на пайтоне в номере 300EF5
Ответ: 11

Номер: 8AD3E2

Впишите правильный ответ.
Сколько существует натуральных чисел x, для которых выполняется неравенство EB16 < x < EF16?

В ответе укажите только количество чисел, сами числа писать не нужно.

Решение:

def convert_to_decimal(number_str, base):
    """Преобразует строку числа в указанной системе счисления в десятичное число."""
    return int(number_str, base)

def count_natural_numbers(a, b):
    """Считает количество натуральных чисел x, для которых выполняется a < x < b."""
    if a >= b:
        return 0
    return max(0, b - a - 1)

# Запрашиваем у пользователя ввод чисел и систем счисления
a_input = input("Введите число a: ")
a_base = int(input("Введите систему счисления для a (например, 10 для десятичной): "))
b_input = input("Введите число b: ")
b_base = int(input("Введите систему счисления для b (например, 10 для десятичной): "))

# Преобразуем числа a и b в десятичную систему
a_decimal = convert_to_decimal(a_input, a_base)
b_decimal = convert_to_decimal(b_input, b_base)

# Считаем количество натуральных чисел x
count = count_natural_numbers(a_decimal, b_decimal)

# Выводим результат
print(f"Количество натуральных чисел x, для которых выполняется {a_decimal} < x < {b_decimal}: {count}")

Ответ: 3

Номер: 84C1E2

Впишите правильный ответ.
Вычислите значение выражения FE16 – F916.

В ответе запишите вычисленное значение в десятичной системе счисления.

Решение:

Решение на пайтоне в номере 300EF5
FE16 = 25410
F916 = 24910
254-249=5
Ответ: 5

Номер: FD0462

Впишите правильный ответ.
Сколько существует натуральных чисел x, для которых выполнено неравенство 110110102 < x < DF16?

В ответе укажите только количество чисел, сами числа писать не нужно.

Решение:

Образец решения на пайтон в номере 84C1E2
110110102 = 21810
DF16 = 22310
219,220,221,222 -  4 числа
Ответ: 4

Номер: 82F46F

Впишите правильный ответ.
Вычислите значение выражения 6B16 – 6516.

В ответе запишите вычисленное значение в десятичной системе счисления.

Решение:

Решение на пайтоне в номере 300EF5
6B16 = 10710
6516 = 10110
107-101=6
Ответ: 6

Номер: CED437

Впишите правильный ответ.
Вычислите значение выражения 9F16 – 9216.

В ответе запишите вычисленное значение в десятичной системе счисления.

Решение:

int('9F', 16) - int('92', 16)
Ответ: 13

Номер: 6DED13

Тут 16-е в тех же КЭС завалялось, пока оставляем, чтобы не потерять. Не обращайте внимания.
Впишите правильный ответ.
Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями:

F(n) = n при n >= 2025;

F(n) = n + F(n + 2), если n < 2025.

Чему равно значение выражения F(2022) – F(2023)?

КЭС: 2.2 Теоретические подходы к оценке количества информации. Единицы измерения количества информации. Алфавитный подход к оценке количества информации. Закон аддитивности информации. Формула Хартли. Информация и вероятность. Формула Шеннона
2.5 Кодирование текстов. Кодировка ASCII. Однобайтные кодировки. Стандарт UNICODE. Кодировка UTF-8. Определение информационного объёма текстовых сообщений
2.6 Кодирование изображений. Оценка информационного объёма графических данных при заданных разрешении и глубине кодирования цвета. Цветовые модели. Кодирование звука. Оценка информационного объёма звуковых данных при заданных частоте дискретизации и разрядности кодирования

Решение:

...
Ответ:

Номер: 2E8064

Задания устаревшего формата

Выберите правильный ответ.
Вычислите сумму чисел x и y, при x= B416, y= 468.

Результат представьте в двоичной системе счисления.

1) 110110102
2) 100000102
3) 11100102
4) 101110102

Решение:

Ответ: 1

Номер: ADDC40

Выберите правильный ответ.
Вычислите сумму чисел x и y, при x = A716, y = 568.

Результат представьте в двоичной системе счисления.

1) 110101012
2) 110010012
3) 100011112
4) 100001012

Решение:

Ответ: 1

Номер: C46CFB

Выберите правильный ответ.
Для кодирования букв А, Б, В, Г решили использовать двухразрядные последовательные двоичные числа (от 00 до 11 соответственно). Если таким способом закодировать последовательность символов ГБВА и записать результат шестнадцатеричным кодом, то получится:

1) 138
2) DBCA
3) D8
4) 3120

КЭС: 2.1 Двоичное кодирование. Равномерные и неравномерные коды. Декодирование сообщений, записанных с помощью неравномерных кодов. Условие Фано. Построение однозначно декодируемых кодов с помощью дерева
2.2 Теоретические подходы к оценке количества информации. Единицы измерения количества информации. Алфавитный подход к оценке количества информации. Закон аддитивности информации. Формула Хартли. Информация и вероятность. Формула Шеннона

Решение:

Закодируем двоичным кодом каждую букву:
А — 00
Б — 01
В — 10
Г — 11
Закодируем последовательность букв ГБВА, используя кодировку букв:
11011000
110110002=D816
Ответ: 3

Номер: E5CC26

Выберите правильный ответ.
Сколько единиц в двоичной записи числа 197?

1) 5
2) 2
3) 3
4) 4

Решение:

19710 = 110001012
4 единицы
Ответ: 4

Номер: BA0D12

Выберите правильный ответ.
Количество значащих нулей в двоичной записи десятичного числа 129 равно

1) 5
2) 6
3) 7
4) 4

Решение:

12910 = 100000012
6 нулей
Ответ: 2

Номер: 74169D

Выберите правильный ответ.
Сколько единиц в двоичной записи числа 195?

1) 5
2) 2
3) 3
4) 4

Решение:

19510 = 110000112
Ответ: 4

Номер: 1C936F

Выберите правильный ответ.
Количество значащих нулей в двоичной записи десятичного числа 126 равно

1) 1
2) 2
3) 3
4) 0

Решение:

12610 = 11111102
Ответ: 1

Номер: 1DDE36

Выберите правильный ответ.
Вычислите сумму чисел x и y, при x = 1D16, y = 728.

Результат представьте в двоичной системе счисления.

1) 100011112
2) 11001012
3) 1010112
4) 10101112

Решение:

1D16 = 2910
728 = 5810
29+58=87
8710 = 10101112
Ответ: 4

Номер: 5E15D4