Собрали ассорти из заданий по комбинаторике с реальных ЕГЭ и из сборников разных авторов.

Нумерация списков начинается с единицы.

Задание 8. Информатика.

Задание 8. Информатика. ЕГЭ. Основная волна. 11.06.2025

Все пятибуквенные слова, составленные из букв С, Т, Р,О, К, А, записаны в алфавитном порядке и пронумерованы. Вот начало списка:

ААААА
ААААК
ААААО
ААААС
ААААТ
Определите, под каким номером в этом списке стоит последнее слово с нечётным номером, которое не начинается с букв А или Л и при этом содержит в своей записи ровно одну букву С. Примечание: Слово — последовательность идущих подряд букв, не обязательно осмысленная.

Решение:

Python


from itertools import product

n = 0
for i, p in enumerate(product('АКОРСТ', repeat=5), 1):
    if p[0] not in 'АЛ' and p.count('С') == 1 and i % 2 == 1:
        n = i
print(n)

Ответ: \(7775\)

Проверка на букву 'Л' в условии избыточна, так как эта буква отсутствует в исходном алфавите ('АКОРСТ'). Но для наглядности включили в код.

Задание 8. Информатика. ЕГЭ. Основная волна. 10.06.2025-2

Все шестибуквенные слова, составленные из букв Т, Е, О, Р, И, Я, записаны в алфавитном порядке и пронумерованы. Вот начало списка:

  1. ЕЕЕЕЕЕ
  2. ЕЕЕЕЕИ
  3. ЕЕЕЕЕО
  4. ЕЕЕЕЕР
  5. ЕЕЕЕЕТ

Определите, под каким номером в этом списке стоит последнее слово с нечётным номером, которое не начинается с букв Е, И или О и при этом содержит в своей записи ровно одну букву Т. Примечание: Слово — последовательность идущих подряд букв, не обязательно осмысленная.

Решение:

Python


from itertools import product
alph = 'ЕИОРТЯ'

n = 0
for i, p in enumerate(product(alph, repeat=6), 1):
    if i % 2 == 1 and p[0] not in 'ЕИО' and p.count('Т') == 1:
        n = i
print(n)

Ответ: \(46655\)

Задание 8. Информатика. ЕГЭ. Основная волна. 10.06.2025

Все пятибуквенные слова, составленные из букв B, E, H, E, P, А записаны в алфавитном порядке и пронумерованы. Вот начало списка:

  1. ААААА
  2. ААААВ
  3. ААААЕ
  4. ААААН
  5. ААААР

Под каким нечетным номером в списке стоит последнее слово, которое не начинается с буквы Н и содержит ровно две буквы В?

Решение:

Python


from itertools import product
alph = 'АВЕНР'

n = 0
for i, p in enumerate(product(alph, repeat=5), 1):
    if i % 2 == 1 and p[0] != 'Н' and p.count('В') == 2:
        n = i
print(n)

Ответ: \(3107\)

ЕГЭ. Апробация. 14.05.2025-1

Игорь составляет таблицу кодовых слов для передачи сообщений: каждому сообщению соответствует своё кодовое слово. В качестве кодовых Игорь использует шестибуквенные слова, в которых есть только буквы М, А, С, Л, О, причём буква С встречается ровно \(1\) раз. Каждая из других допустимых букв может встречаться любое количество раз или не встречаться совсем. Слово не должно начинаться с гласной буквы и оканчиваться согласной. Сколько различных кодовых слов может использовать Игорь?

Примечание. Словом считается непрерывная последовательность букв, не обязательно имеющая смысл.

Решение:

Python


from itertools import product

alph = 'МАСЛО'
vowels = 'АО'
q = 0

for p in product(alph, repeat=6):
    q += p.count('С') == 1 and p[0] not in vowels and p[-1] in vowels
print(q)

Ответ: \(1536\)

ЕГЭ. ЕГКР. 19.04.2025

Все шестибуквенные слова, в составе которых могут быть только буквы П, О, Б, Е, Д, А, записаны в алфавитном порядке и пронумерованы начиная с \(1.\) Ниже приведено начало списка.

1. АААААА
2. АААААБ
3. АААААД
4. АААААЕ
5. АААААО
6. АААААП
...
Определите последний чётный номер слова, которое начинается с буквы О и в котором каждая буква встречается ровно один раз.

Примечание. Слово — последовательность идущих подряд букв, не обязательно осмысленная.

Решение:

Python


from itertools import product, repeat

last = 0
for i, w in enumerate(product('АБДЕОП', repeat=6), 1):
    if w[0] == 'О' and len(set(w)) == 6 and i % 2 == 0:
        last = i
print(last)

Ответ: \(38306\)

ЕГЭ. Досрочный экзамен. 08.04.2025

Виктор составляет таблицу кодовых слов для передачи сообщений, каждому сообщению соответствует своё кодовое слово. В качестве кодовых слов Виктор использует \(5\)-буквенные слова, в которых могут быть только буквы Д, Г, И, А, Ш, Э, причём слово не должно начинаться с гласной или заканчиваться согласной. Сколько различных кодовых слов может использовать Виктор?

Решение:

Python


from itertools import product

alph = 'ДГИАШЭ'
vow = 'ИАЭ'

words = set()
for p in product(alph, repeat=5):
    if p[0] not in vow and p[-1] in vow:
        words.add(''.join(p))
print(len(words))

Ответ: \(1944\)

ЕГЭ. Апробация. 05.03.2025-2

Все пятибуквенные слова, в составе которых могут быть только буквы Ф, О, К, У, С, записаны в алфавитном порядке и пронумерованы начиная с \(1.\) Ниже приведено начало списка.

1. ККККК
2. ККККО
3. ККККС
4. ККККУ
5. ККККФ
6. КККОК
...
Под каким номеров в списке идёт последнее слово, которое не содержит букв Ф и содержит ровно две буквы У?

Решение:

Python


from itertools import product
symb = sorted(list('ФОКУС'))

n = 0
for i, p in enumerate(product(symb, repeat=5), 1):
    if p.count('Ф') == 0 and p.count('У') == 2:
        n = i
print(n)

Ответ: \(2313\)

ЕГЭ. Апробация. 05.03.2025

Определите количество девятеричных пятизначных чисел, в записи которых ровно одна цифра \(0,\) при этом никакая нечётная цифра не стоит рядом с цифрой \(0.\)

Решение:

Python


from itertools import product

alph = '012345678'
deny = ('01', '03', '05', '07', '10', '30', '50', '70')

q = 0
for p in product(alph, repeat=5):
    n = ''.join(p)
    q += n[0] != '0' and n.count('0') == 1 and all(c not in n for c in deny)
print(q)

Ответ: \(5120\)

ЕГЭ. Шастин. 7.6.2025

(Л. Шастин) Все пятибуквенные слова, составленные из букв слова ЖИВОДЁРНЯ, записаны в алфавитном порядке и пронумерованы. Вот начало списка:

1. ВВВВВ
2. ВВВВД
3. ВВВВЁ
4. ВВВВЖ
5. ВВВВИ
6. ВВВВН
7. ВВВВО
8. ВВВВР
Под каким номером в списке стоит последнее слово с чётным номером, которое начинается и заканчивается на одну и ту же букву и содержит не менее двух букв Р?

Решение:

Python


from itertools import product

n = 0
for i, p in enumerate(product('ВДЁЖИНОРЯ', repeat=5)):
    if i % 2 == 0 and p[0] == p[-1] and p.count('Р') > 1:
        n = i
print(n)

Ответ: \(58958\)

ЕГЭ. Шастин. 5.6.2025

(Л. Шастин) Определите количество \(16\)-ричных пятизначных чисел, в записи которых содержится не менее одной цифры \(7\) и ровно две цифры с числовым значением, превышающим \(12,\) причём стоящие рядом.

Решение:

Python


from itertools import product

alph = '0123456789ABCDEF'

q = 0
for p in product(alph, repeat=5):
    n = ''.join(p)
    for ch in 'EF':
        n = n.replace(ch, 'D')
    q += n[0] != '0' and '7' in n and 'DD' in n and n.count('D') == 2
print(q)

Ответ: \(16209\)

ЕГЭ. Шастин. 3.6.2025

(Л. Шастин) Сколько существует тринадцатеричных семизначных чисел, в которых все цифры различны и никакая нечётная цифра не стоит рядом с цифрой \(B?\)

Решение:

Python


from itertools import permutations

alph = '0123456789ABC'

q = 0
for p in permutations(alph, 7):
    num = ''.join(p)
    for ch in '3579':
        num = num.replace(ch, '1')
    q += num[0] != '0' and 'B1' not in num and '1B' not in num
print(q)

Ответ: \(5372640\)

ЕГЭ. Шастин. 1.6.2025

(Л. Шастин) Все пятибуквенные слова, составленные из букв слова ЦИФЕРБЛАТ, записаны в алфавитном порядке и пронумерованы. Вот начало списка:

1. ААААА
2. ААААБ
3. ААААЕ
4. ААААИ
5. ААААЛ
6. ААААР
7. ААААТ
8. ААААФ
Сколько в этом списке слов с нечётными номерами, которые не начинаются с гласной буквы и содержат равное количество букв Ц и Ф.

Решение:

Python


from itertools import product

q = 0
for i, w in enumerate(product('АБЕИЛРТФЦ', repeat=5), 1):
    q += i % 2 == 1 and w[0] not in 'АЕИ' and w.count('Ц') == w.count('Ф')
print(q)

Ответ: \(7454\)

ЕГЭ. Статград. Профиль. 12.05.2025-1

Определите количество восьмизначных \(15\)-ричных чисел, в записи которых каждая цифра встречается не более одного раза и запись содержит одинаковое количество чётных и нечётных цифр.

Решение:

В алфавите \(15\)-ричной системы счисления \(8\) чётных цифр и \(7\) нечётных. Запись \(8\)-значного числа из условия задачи состоит из \(4\) различных чётных цифр, которых можно выбрать из алфавита \(C_8^4\) способами, и из \(4\) различных нечётных цифр, всего способов их выбрать из алфавита \(C_7^4\). Выбрать из \(8\) позиций \(8\)-значного числа \(4\) позиции под чётные числа можно \(C_8^4\) способами. В каждом фиксированном выборе четырех позиций и конкретном выборе \(4\) чётных цифр можно выполнить \(4!\) перестановок этих цифр. Аналогичные действия можно выполнить и с нечётными цифрами. Всего получается $$C_8^4 \cdot C_8^4 \cdot 4! \cdot C_7^4 \cdot 4!.$$ различных чисел. Однако среди этих чисел присутствуют те, которые начинаются с цифры \(0\). Посчитаем их количество и исключим их из общего количества. На первом месте стоит \(0,\) значит среди оставшихся \(7\) позиций на трёх стоят чётные цифры. Всего вариантов выбрать три цифры из \(7\) чётных (ноль мы уже исключили) \(C_7^3.\) Под них выбрать \(3\) позиции из оставшихся \(7\) в нашем числе можно тоже \(C_7^3\) способами. Наконец, эти три чётные цифры можно переставить \(3!\) способами. Аналогичные рассуждения проводим и для нечётных цифр. Окончательная формула следующая: $$C_8^4 \cdot C_8^4 \cdot 4! \cdot C_7^4 \cdot 4! - C_7^3 \cdot C_7^3 \cdot 3! \cdot C_7^4 \cdot 4!$$

Python


from math import comb, factorial
N = comb(8, 4) * comb(8, 4) * factorial(4) * comb(7, 4) * factorial(4)
N -= comb(7, 3) * comb(7, 3) * factorial(3) * comb(7, 4) * factorial(4)
print(N)

Ответ: \(92610000\)

ЕГЭ. Статград. База. 12.05.2025-1

Определите количество тринадцатеричных шестизначных чисел, в записи которых ровно две цифры \(1,\) при этом никакая чётная цифра не стоит рядом с цифрой, числовое значение которой превышает \(9.\)

Решение:

Python


from itertools import product

alph = '0123456789ABC'
even = alph[::2]
deny = [''.join(p) for p in product(even, 'ABC')] + [''.join(p) for p in product('ABC', even)]
q = 0

for p in product(alph, repeat=6):
    num = ''.join(p)
    q += num[0] != '0' and num.count('1') == 2 and all(''.join(c) not in deny for c in zip(num, num[1:]))
print(q)

Ответ: \(173057\)

ЕГЭ. Шастин. 7.05.2025

(Л. Шастин) Сколько существует шестизначных чисел, записанных в семнадцатеричной системе счисления, в которых все цифры различны и никакие три чётные или три нечётные цифры не стоят рядом?

Решение:

Python


from itertools import permutations

alph = '0123456789ABCDEFG'
even = alph[::2]
q = 0
for p in permutations(alph, 6):
    if p[0] == '0':
        continue
    if any(all(c in even for c in p[i:3+i]) for i in range(4)) \
        or any(all(c not in even for c in p[i:3+i]) for i in range(4)):
        continue
    q += 1
print(q)

Ответ: \(3873408\)

ЕГЭ. Демо-2025

Определите количество \(12\)-ричных пятизначных чисел, в записи которых ровно одна цифра \(7\) и не более трёх цифр с числовым значением, превышающим \(8\).

Решение:

Python


alph = '0123456789AB'

q = 0

for a in alph[1:]:
    for b in alph:
        for c in alph:
            for d in alph:
                for e in alph:
                    t = a + b + c + d + e
                    s = t.count('9') + t.count('A') + t.count('B')
                    if t.count('7') == 1 and s <= 3:
                        q += 1

print(q)

Ответ: \(67476\)

ЕГЭ. ЕГКР. 21.12.2024

Все пятибуквенные слова, в составе которых могут быть только русские буквы Я, Н, В, А, Р, Ь, записаны в алфавитном порядке и пронумерованы начиная с \(1\). Ниже приведено начало списка.

1. ААААА
2. ААААВ
3. ААААН
4. ААААР
5. ААААЬ
6. ААААЯ
7. АААВА
...
Под каким номером в списке идёт последнее слово, которое не начинается с буквы Я, содержит не более одной буквы Ь и не содержит букв Я, стоящих рядом?

Решение:

Python


from itertools import product

n = 0
for i, p in enumerate(product('АВНРЬЯ', repeat=5), 1):
    w = ''.join(p)
    if w[0] != 'Я' and w.count('Ь') < 2 and 'ЯЯ' not in w:
        n = i
print(n)

Ответ: \(6406\)

ЕГЭ 2024. Пересдача. 04.07.2024

Все пятибуквенные слова, в составе которых могут быть только русские буквы Л, А, Й, М, записаны в алфавитном порядке и пронумерованы начиная с \(1\).

Ниже приведено начало списка:

1. ААААА
2. ААААЙ
3. ААААЛ
4. ААААМ
5. АААЙА
...
Под каким номером в списке идёт последнее слово, которое не содержит ни одной буквы М, ни одной буквы Л и не содержит букв Й, стоящих рядом?

Решение:

Python

Первый способ


s = 'АЙЛМ'

arr = []
i = 0

for a in s:
    for b in s:
        for c in s:
            for d in s:
                for e in s:
                    i += 1
                    w = a + b + c + d + e
                    if w.count('М') == 0 and w.count('Л') == 0 and 'ЙЙ' not in w:
                        arr.append(i)

print(arr[-1])

Второй способ


from itertools import product

a = []
for n, w in enumerate(product('АЙЛМ', repeat=5)):
    s = ''.join(w)
    if s.count('М') == 0 and s.count('Л')== 0 and 'ЙЙ' not in s:
        a.append(n+1)

print(a[-1])

Ответ: \(274\)

ЕГЭ 2024. Основная волна. 07.06.2024

Определите количество восьмеричных пятизначных чисел, которые не начинаются с нечётных цифр, не оканчиваются цифрами \(2\) или \(6\), а также содержат не более двух цифр \(7\).

Решение:

Python


alph = '01234567'
alph_begin = '246'
alph_end = '013457'

q = 0

for a in alph_begin:
    for b in alph:
        for c in alph:
            for d in alph:
                for e in alph_end:
                    n = a + b + c + d + e
                    if n.count('7') <= 2:
                        q += 1

print(q)

Ответ: \(9135\)

ЕГЭ. Статград. 01.04.2025-1

Все 5-буквенные слова, в составе которых могут быть только буквы Э, Л, Ь, Б, Р, У, С, записаны в алфавитном порядке и пронумерованы. Вот начало списка:

1. БББББ
2. ББББЛ
3. ББББР
4. ББББС
5. ББББУ
6. ББББЬ
...
Под каким номером в списке идёт последнее слово c чётным номером, которое содержит не менее двух букв С, одну букву Л и не содержит букв Э, стоящих рядом?

Решение:

Python


from itertools import product

chars = 'БЛРСУЬЭ'
n = 0

for i, p in enumerate(product(chars, repeat=5), 1):
    word = ''.join(p)
    if i % 2 == 0 and word.count('С') > 1 and word.count('Л') == 1 \
        and 'ЭЭ' not in word:
        n = i
print(n)

Ответ: \(15948\)

ЕГЭ. Статград. 04.03.2025

Сколько существует натуральных чисел, запись которых в системе счисления с основанием \(12\) содержит не менее двух цифр, и при чтении числа слева направо каждая следующая цифра оказывается строго больше предыдущей?

Решение:

Решение:

Число не может начинаться с \(0.\) А так как все цифры в числе идут в строго возрастающем порядке, то цифра \(0\) вообще не может встретиться в числах, удовлетворяющих условию задачи. Максимальное число, подходящее под условие задачи — это \(11\)-значное число \(123456789AB.\) Количество \(n\)-значных \((n < 12)\) \(12\)-ричных чисел, у которых все цифры стоят в строго возрастающем порядке равно \(C_{11}^n,\) а всего чисел, удовлетворяющих условию задачи равно $$\sum_{i=2}^{11} C_{11}^i$$

Python


from math import comb

print(sum(comb(11, x) for x in range(2, 12)))

Ответ: \(2036\)

ЕГЭ. Статград. 28.01.2025-1

Сколько существует натуральных чисел, не превышающих \(855~000~000,\) запись которых в системе счисления с основанием \(15\) содержит ровно \(8\) различных цифр?

Решение:

Переведём число \(855~000~000\) в \(15\)-ричную систему счисления.

Python


def conv(n):
    alph = '0123456789ABCDE'
    ans = ''
    while n:
        ans = alph[n % 15] + ans
        n //= 15
    return ans

print(conv(855_000_000))

Поучаем, что \(855~000~000 = 500DD500_{15}.\) Понятно, нет чисел, не превышающих \(855~000~000,\) которые в \(15\)-ричной записи имеют ровно \(8\) различных цифр и которые в такой СИ начинаются с \(5.\) Таки образом, все числа, удовлетворяющие условию задачи должны в \(15\)-ричной системе счисления начинаться либо с \(1\), либо с \(2\), либо с \(3\), либо с \(4\). Всего существует $$4 \cdot A_{14}^7 = 4 \cdot 14 \cdot 13 \cdot 12 \cdot 11 \cdot 10 \cdot 9 \cdot 8 = 69189120 $$ таких чисел.

Ответ: \(69189120\)

ЕГЭ. Статград. 17.12.2024-1

Джон составляет список всех возможных кодов, составленных из заглавных латинских букв. Сначала он выписывает в алфавитном порядке все коды, состоящие из одного символа (A, B, …, Z), затем – тоже в алфавитном порядке – коды из двух символов (AA, AB, …, AZ, BA, BB, … ZZ), далее идут трёхсимвольные коды (AAA, AAB, …, ZZZ) и так далее. Под каким номером окажется в этом списке код FEDABC?

Решение:

$$26 + 26^2 + 26^3 + 26^4 + 26^5 + 5 \cdot 26^5 + 4 \cdot 26^4 + 3 \cdot 26^3 + 26 + 2 + 1 = 73644171$$

Программно:

Python


from itertools import product

b = sum(26**n for n in range(1, 6))
for i, p in enumerate(product('ABCDEFGHIJKLMNOPQRSTUVWXYZ', repeat=6), b + 1):
    if p == ('F', 'E', 'D', 'A', 'B', 'C'):
        print(i)
        break

Ответ: \(73644171\)

ЕГЭ. Статград. 24.10.2024-2

Определите количество восьмизначных \(16\)-ричных чисел, в записи которых ровно два нуля и не более четырёх цифр, для записи которых используются буквы.

Решение:

\(C^2_7 \cdot (15^6 - 6^6 - 6 \cdot 9 \cdot 6^5)\)
Ответ: \(229~405~365\)

ЕГЭ. Статград. 24.10.2024-1

Определите количество восьмизначных \(15\)-ричных чисел, в записи которых ровно два нуля и не более четырёх цифр, для записи которых используются буквы.

Решение:

\(C^2_7 \cdot (14^6 - 5^6 - 6 \cdot 9 \cdot 5^5)\)
Ответ: \(154~248~381\)

ЕГЭ. Шастин. 13.03.2025

(Д. Бахтиев) Все пятибуквенные слова, в составе которых могут быть только русские буквы Ч, М, С, Е, И, А, К записаны в алфавитном порядке и пронумерованы начиная с \(1.\) Ниже приведено начало списка:

1. ААААА
2. ААААЕ
3. ААААИ
4. ААААК
5. ААААМ
6. ААААС
7. ААААЧ
8. АААЕА
...
Определите сколько слов находится между словом «МАСИК» и «ЧЕЧИК» (не включая эти слова).

Решение:

Python


from itertools import product

masik, chechik = 0, 0

for i, p in enumerate(product('АЕИКМСЧ', repeat=5), 1):
    w = ''.join(p)
    if w == 'МАСИК':
        masik = i
    elif w == 'ЧЕЧИК':
        chechik = i
        break
print(chechik - masik - 1)

Ответ: \(5193\)

ЕГЭ. Шастин. 9.2.2025

(Д. Бахтиев) Все шестибуквенные слова, в составе которых могут быть только русские буквы С, И, Н, Е, Р, Г, Я записаны в алфавитном порядке и пронумерованы начиная с \(1.\) Ниже приведено начало списка.

ГГГГГГ
ГГГГГЕ
ГГГГГИ
ГГГГГН
ГГГГГР
ГГГГГС
ГГГГГЯ
ГГГГЕГ
...
Определите номер последнего слова, которое содержит сочетание букв «ГИРЯ». В ответе укажите только число.

Решение:

Python


from itertools import product

pos = []

for i, p in enumerate(product('ГЕИНРСЯ', repeat=6), 1):
    if 'ГИРЯ' in ''.join(p):
        pos.append(i)

print(pos[-1])

Ответ: \(115381\)

ЕГЭ. Шастин. 19.01.2025

(Л. Шастин) Леонид составляет коды перестановкой букв слова ПАРИЖАНКА. При этом в этих кодах ровно один раз встречаются две идущие подряд гласные буквы. Сколько различных кодов может составить Леонид?

Решение:

Python


from itertools import permutations

ans = set()
allow = ('АА', 'АИ', 'ИА')
deny = ('ААА', 'ИАА', 'АИА', 'ААИ')
for p in permutations('ПАРИЖАНКА'):
    s = ''.join(p)
    if sum(s.count(a) for a in allow) == 1 and all(d not in s for d in deny):
        ans.add(s)
print(len(ans))

Ответ: \(28800\)

ЕГЭ. Шастин. 18.12.2024

(Д. Бахтиев) Дионисий составляет 6-буквенные слова из букв своего имени, причём в слове обязательно должна присутствовать буква Д или буква Н, но не обе сразу. Каждая из других допустимых букв может встречаться в слове любое количество раз или не встречаться совсем, но при этом в слове не должно быть двух одинаковых букв, стоящих рядом. Словом считается любая допустимая последовательность букв, не обязательно осмысленная. Сколько существует таких слов, которые может написать Дионисий?

Решение:

Python


from itertools import product

forb = ('ИИ', 'ОО', 'СС', 'ЙЙ', 'ДД', 'НН')

q = 0
for p in product('ДИОНСЙ', repeat=6):
    w = ''.join(p)
    q += (('Д' in w) != ('Н' in w)) and all(x not in w for x in forb)
print(q)

Ответ: \(8296\)

ЕГЭ. Шастин. 30.11.2024

(Л. Шастин) Чересчур любопытная Варвара решила посчитать количество двоичных цепочек, состоящих из \(20\) бит, содержащих ровно \(0 < K < 20\) нулей, и получила в итоге шестизначное число. Чему равно максимально возможное \(K?\) В ответе укажите количество битовых цепочек, соответствующих данному значению \(K.\)

Решение:

Python


from math import comb

for k in range(19, 0, -1):
    if 99_999 < comb(20, k) < 1_000_000:
        print(comb(20, k))
        break

Ответ: \(125970\)

ЕГЭ. Шастин. 6.11.2024

(Д. Бахтиев) Павсикакий составляет шестибуквенные слова в алфавитном порядке из букв своего имени, но нумерует только те из них, которые содержат хотя бы две гласные, стоящие рядом. Вот начало списка:

АААААА
АААААВ
АААААИ
АААААЙ
АААААК
...
Под каким номером стоит слово КАКААА?

Решение:

Python


from itertools import product

alph = sorted(list(set('ПАВСИКАКИЙ')))
allow = ('АА', 'АИ', 'ИА', 'ИИ')
n = 0

for p in product(alph, repeat=6):
    word = ''.join(p)
    if any(s in word for s in allow):
        n += 1
        if word == 'КАКААА':
            print(n)
            break

Ответ: \(23611\)

ЕГЭ. Шастин. 18.10.2024

(Л. Шастин) Определите количество \(12\)-ричных шестизначных чисел, в записи которых содержится ровно одно цифра «\(B\)» и равное количество чётных и нечётных цифр.

Решение:

Python


from itertools import product

def count_sym(s, p):
    odd_sym = '13579B'
    even_sym = '02468A'
    if p:
        return sum(c in odd_sym for c in s)
    else:
        return sum(c in even_sym for c in s)

alph = '0123456789AB'
q = 0
for p in product(alph, repeat=6):
    if p[0] == '0':
        continue
    num = ''.join(p)
    q += int(num.count('B') == 1 and count_sym(num, 0) == count_sym(num, 1))
print(q)

Ответ: \(297000\)

ЕГЭ. Шастин. 4.10.2024

(Д. Бахтиев) Все пятибуквенные слова, в составе которых могут быть только русские буквы П, Р, Е, С, Т, О, Л, записаны в алфавитном порядке и перенумерованы начиная с \(1\). Вот начало списка:

ЕЕЕЕЕ
ЕЕЕЕЛ
ЕЕЕЕО
ЕЕЕЕП
ЕЕЕЕР
...
Сколько слов в списке с нечётным номером оканчиваются на гласную букву и содержат не более трёх согласных в своём составе?

В ответе укажите только число.

Решение:

Python


from itertools import product

def valid(s):
    consonant = 'ПРСТЛ'
    vowel = 'ОЕ'
    return s[-1] in vowel and sum(ch in consonant for ch in s) < 4

q = 0
for i, p in enumerate(product('ЕЛОПРСТ', repeat=5)):
    q += int(i % 2 == 0 and valid(''.join(p)))
print(q)

Ответ: \(1776\)

ЕГЭ. Шастин. 19.09.2024

(Л. Шастин) Ваня составляет \(5\)-буквенные слова, в которых могут быть использованы только буквы Л, Ю, С, Т, Р, А, причём буква Ю используется не более двух раз. Каждая из других допустимых букв может встречаться в слове любое количество раз или не встречаться совсем. Также слово не должно оканчиваться согласными буквами. Словом считается любая допустимая последовательность букв, не обязательно осмысленная Сколько существует таких слов, которые может написать Ваня?

Решение:

Python


from itertools import product

s = 'ЛЮСТРА'
q = 0

for p in product(s, repeat=5):
    q += int(p.count('Ю') < 3 and p[-1] not in 'ЛСТР')
print(q)

Ответ: \(2400\)

ЕГЭ. Шастин. 29.08.2024

Все пятибуквенные слова, составленные из букв С, Е, Н, Т, Я, Б, Р, Ь, записаны в алфавитном порядке и пронумерованы. Ниже приведено начало списка.

БББББ
ББББЕ
ББББН
ББББР
ББББС
ББББТ
ББББЬ
ББББЯ
Под каким номером в списке стоит последнее слово с чётным номером, которое начинается с буквы Р и не содержит букву Ь?

Решение:

Python


word = 'БЕНРСТЬЯ'

i = 0
ans = 0
for a in word:
    for b in word:
        for c in word:
            for d in word:
                for e in word:
                    w = a + b + c + d + e
                    i += 1
                    if i % 2 == 0 and a == 'Р' and w.count('Ь') == 0:
                        ans = i
print(ans)

Ответ: \(16384\)