ЕГЭ 2024. Крылов-20

Шифр кодового замка представляет собой последовательность из трёх символов, каждый из которых является цифрой от \(1\) до \(4\). Сколько различных вариантов шифра можно задать, если известно, что цифра \(2\) должна встречаться в коде ровно один раз, а каждая из других допустимых цифр может встречаться в шифре любое количество раз или не встречаться совсем?

Решение:

Python


nums = [1, 2, 3, 4]

q = 0

for a in nums:
    for b in nums:
        for c in nums:
            if [a, b, c].count(2) == 1:
                q += 1

print(q)

Ответ: \(27\)

ЕГЭ 2024. Крылов-19

Шифр кодового замка представляет собой последовательность из пяти символов, каждый из которых является цифрой от \(1\) до \(6\). Сколько различных вариантов шифра можно задать, если известно, что цифра \(1\) должна встречаться в коде ровно один раз, а каждая из других допустимых цифр может встречаться в шифре любое количество раз или не встречаться совсем?

Решение:

Python


nums = [1, 2, 3, 4, 5, 6]

q = 0

for a in nums:
    for b in nums:
        for c in nums:
            for d in nums:
                for e in nums:
                    if [a, b, c, d, e].count(1) == 1:
                        q += 1

print(q)

Ответ: \(3125\)

ЕГЭ 2024. Крылов-18

Сколько существует различных четырёхзначных чисел, записанных в десятичной системе счисления, в записи которых есть ровно две одинаковые цифры, причём стоящие рядом?

Решение:

Python


nums = [0, 1, 2, 3, 4, 5, 6, 7, 8, 9]

q = 0

for a in nums[1:]:
    for b in nums:
        for c in nums:
            for d in nums:
                arr = [a, b, c, d]
                if len(set(arr)) == 3 and any(x == y for x, y in zip(arr, arr[1:])):
                    q += 1

print(q)

Ответ: \(1944\)

ЕГЭ 2024. Крылов-17

Сколько существует различных четырёхзначных чисел, записанных в восьмеричной системе счисления, в записи которых есть ровно две одинаковые цифры, причём стоящие рядом?

Решение:

Python


nums = [0, 1, 2, 3, 4, 5, 6, 7]

q = 0

for a in nums[1:]:
    for b in nums:
        for c in nums:
            for d in nums:
                arr = [a, b, c, d]
                if len(set(arr)) == 3 and any(x == y for x, y in zip(arr, arr[1:])):
                    q += 1

print(q)

Ответ: \(882\)

ЕГЭ 2024. Крылов-16

Сколько существует различных трёхзначных чисел, записанных в пятеричной системе счисления, в записи которых цифры следуют слева направо в невозрастающем порядке?

Решение:

Python


nums = [0, 1, 2, 3, 4]

arr = []
q = 0

for a in nums[1:]:
    for b in nums:
        for c in nums:
            if a >= b >= c:
                q += 1

print(q)

Ответ: \(34\)

ЕГЭ 2024. Крылов-15

Сколько существует различных трёхзначных чисел, записанных в четверичной системе счисления, в записи которых цифры следуют слева направо в невозрастающем порядке?

Решение:

Python


nums = [0, 1, 2, 3]

arr = []
q = 0

for a in nums[1:]:
    for b in nums:
        for c in nums:
            if a >= b >= c:
                q += 1

print(q)

Ответ: \(19\)

ЕГЭ 2024. Крылов-14

Сколько существует различных трёхзначных чисел, записанных в пятеричной системе счисления, в записи которых цифры следуют слева направо в строго убывающем порядке?

Решение:

Python


nums = [0, 1, 2, 3, 4]

arr = []
q = 0

for a in nums[1:]:
    for b in nums:
        for c in nums:
            if a > b > c:
                q += 1

print(q)

Ответ: \(10\)

ЕГЭ 2024. Крылов-13

Сколько существует различных трёхзначных чисел, записанных в четверичной системе счисления, в записи которых цифры следуют слева направо в строго убывающем порядке?

Решение:

Python


nums = [0, 1, 2, 3]

arr = []
q = 0

for a in nums[1:]:
    for b in nums:
        for c in nums:
            if a > b > c:
                q += 1

print(q)

Ответ: \(4\)

ЕГЭ 2024. Крылов-12

Все шестибуквенные слова, в составе которых могут быть только русские буквы В, А, Л, И, К, записаны в алфавитном порядке и пронумерованы начиная с \(1\).

Ниже приведено начало списка:
1. АААААА
2. АААААВ
3. АААААИ
4. АААААК
5. АААААЛ
6. ААААВА
...

Под каким номером в списке идёт первое слово, которое содержит не более двух букв А, ровно две буквы В, не содержит ни одной буквы И?

Решение:

Python


s = 'АВИКЛ'

i = 0
nums = []

for a in s:
    for b in s:
        for c in s:
            for d in s:
                for e in s:
                    for f in s:
                        w = a + b + c + d + e + f
                        i += 1
                        if w.count('А') < 3 and w.count('В') == 2 and w.count('И') == 0:
                            nums.append(i)

print(nums[0])

Ответ: \(169\)

ЕГЭ 2024. Крылов-11

Все пятибуквенные слова, в составе которых могут быть только русские буквы М, А, С, Л, О, записаны в алфавитном порядке и пронумерованы начиная с \(1\).

Ниже приведено начало списка:
1. ААААА
2. ААААЛ
3. ААААМ
4. ААААО
5. ААААС
6. АААЛА
...

Под каким номером в списке идёт первое слово, которое содержит не более одной буквы А, ровно две буквы М, не содержит ни одной буквы Л?

Решение:

Python


s = 'АЛМОС'

i = 0
nums = []

for a in s:
    for b in s:
        for c in s:
            for d in s:
                for e in s:
                    w = a + b + c + d + e
                    i += 1
                    if w.count('А') < 2 and w.count('М') == 2 and w.count('Л') == 0:
                        nums.append(i)

print(nums[0])

Ответ: \(319\)

ЕГЭ 2024. Крылов-10

Все \(4\)-буквенные слова, в составе которых могут быть только буквы П, Р, А, В, О, записаны в алфавитном порядке и пронумерованы начиная с \(1\).

Ниже приведено начало списка:
1. АААА
2. АААВ
3. АААО
4. АААП
5. ААМР
6. ААВА
7. ААВВ
...

Под каким номером в списке идёт первое слово, которое начинается с буквы П?

Решение:

Python


s = 'АВОПР'

nums = []
i = 0

for a in s:
    for b in s:
        for c in s:
            for d in s:
                i += 1
                w = a + b + c + d
                if a == 'П':
                    nums.append(i)

print(nums[0])

Ответ: \(376\)

ЕГЭ 2024. Крылов-9

Все \(4\)-буквенные слова, в составе которых могут быть только буквы А, Т, О, М, записаны в алфавитном порядке и пронумерованы начиная с \(1\).

Ниже приведено начало списка:
1. АААА
2. АААМ
3. АААО
4. АААТ
5. ААМА
6. ААММ
...

Под каким номером в списке идёт первое слово, которое начинается с буквы О?

Решение:

Python


s = 'АМОТ'

i = 0
nums = []

for a in s:
    for b in s:
        for c in s:
            for d in s:
                w = a + b + c + d
                i += 1
                if a == 'О':
                    nums.append(i)

print(nums[0])

Ответ: \(129\)

ЕГЭ 2024. Крылов-8

Все шестибуквенные слова, в составе которых могут быть только русские буквы П, О, Л, Ь, З, А записаны в алфавитном порядке и пронумерованы начиная с \(1\).

Ниже приведено начало списка:
1. АААААА
2. АААААЗ
3. АААААЛ
4. АААААО
5. АААААП
6. АААААЬ
7. ААААЗА
...

Под каким номером в списке идёт первое слово, которое содержит не более одной буквы Ь, ровно одну букву А и не более двух букв З.

Решение:

Python


s = list('ПОЛЬЗА')
s.sort()

i = 0
arr = []

for a in s:
    for b in s:
        for c in s:
            for d in s:
                for e in s:
                    for f in s:
                        word = a + b + c + d + e + f
                        i += 1
                        if word.count('Ь') < 2 and word.count('А') == 1 and word.count('З') < 3:
                            arr.append(i)

print(arr[0])

Ответ: \(1599\)

ЕГЭ 2024. Крылов-7

Все шестибуквенные слова, в составе которых могут быть только русские буквы С, О, Р, Н, Я, К записаны в алфавитном порядке и пронумерованы начиная с \(1\).

Ниже приведено начало списка:
1. КККККК
2. КККККН
3. КККККО
4. КККККР
5. КККККС
6. КККККЯ
7. ККККНК
...

Под каким номером в списке идёт первое слово, которое содержит не более трёх букв К и ровно две буквы Н.

Решение:

Python


s = list('СОРНЯК')
s.sort()

i = 0
arr = []

for a in s:
    for b in s:
        for c in s:
            for d in s:
                for e in s:
                    for f in s:
                        word = a + b + c + d + e + f
                        i += 1
                        if word.count('К') < 4 and word.count('Я') == 2:
                            arr.append(i)

print(arr[0])

Ответ: \(72\)

ЕГЭ 2024. Крылов-6

Определите количество пятизначных чисел, записанных в четверичной системе счисления, в записи которых ровно одна цифра \(3\), и при этом цифра \(0\) не стоит рядом с цифрой \(3\).

Решение:

Python


alpha = '0123'
q = 0

for a in alpha[1:]:
    for b in alpha:
        for c in alpha:
            for d in alpha:
                for e in alpha:
                    num = a + b + c + d + e
                    if num.count('3') == 1 and '30' not in num and '03' not in num:
                        q += 1

print(q)

Ответ: \(174\)

ЕГЭ 2024. Крылов-5

Определите количество пятизначных чисел, записанных в восьмеричной системе счисления, в записи которой ровно две цифры \(4\), и при этом никакая нечётная цифра не стоит рядом с цифрой \(4\).

Решение:

Python


alpha = '01234567'
q = 0

deny = ('14', '34', '54', '74', '41', '43', '45', '47')

for a in alpha[1:]:
    for b in alpha:
        for c in alpha:
            for d in alpha:
                for e in alpha:
                    num = a + b + c + d + e
                    if num.count('4') == 2 and all([x not in num for x in deny]):
                        q += 1

print(q)

Ответ: \(612\)

ЕГЭ 2024. Крылов-4

Все пятибуквенные слова, составленные из букв И, Н, Т, Е, Г, Р, А, Л записаны в алфавитном порядке и пронумерованы.

Вот начало списка:
1. ААААА
2. ААААГ
3. ААААЕ
4. ААААИ
5. ААААЛ
6. ААААН
7. ААААР
...

Определите в этом списке количество слов с нечётными номерами, которые не начинаются с буквы Т и при этом содержат в своей записи только одну или ровно две буквы Н.

Решение:

Python


s = list('ИНТЕГРАЛ')
s.sort()

i = 0
q = 0

for a in s:
    for b in s:
        for c in s:
            for d in s:
                for e in s:
                    word = a + b + c + d + e
                    i += 1
                    if i % 2 and a != 'Т' and word.count('Н') in (1, 2):
                        q += 1

print(q)

Ответ: \(5992\)

ЕГЭ 2024. Крылов-3

Все пятибуквенные слова, составленные из букв Ф, Л, А, М, И, Н, Г, О записаны в алфавитном порядке и пронумерованы.

Вот начало списка:
1. ААААА
2. ААААГ
3. ААААИ
4. ААААЛ
5. ААААМ
6. ААААН
7. ААААО
...

Определите в этом списке количество слов с нечётными номерами, которые не начинаются с буквы Н и при этом содержат в своей записи не более одной буквы О.

Решение:

Python


s = list('ФЛАМИНГО')
s.sort()

i = 0
q = 0

for a in s:
    for b in s:
        for c in s:
            for d in s:
                for e in s:
                    word = a + b + c + d + e
                    i += 1
                    if i % 2 and a != 'Н' and word.count('О') < 2:
                        q += 1

print(q)

Ответ: \(11907\)

ЕГЭ 2024. Крылов-2

Все шестибуквенные слова, составленные из букв Р, Е, П, Л, И, К, А записаны в алфавитном порядке и пронумерованы.

Вот начало списка:
1. АААААА
2. АААААЕ
3. АААААИ
4. АААААК
5. АААААЛ
6. АААААП
7. АААААР
...

Определите в этом списке количество слов с чётными номерами, которые не начинаются с буквы К и при этом содержат в своей записи не менее двух букв И.

Решение:

Python


s = [ch for ch in 'РЕПЛИКА']
s.sort()
i = 0
count = 0

for a in s:
    for b in s:
        for c in s:
            for d in s:
                for e in s:
                    for f in s:
                        word = a+b+c+d+e+f
                        i += 1
                        if i % 2 == 0 and a != 'К' and word.count('И') > 1:
                            count += 1

print(count)

Ответ: \(10892\)

ЕГЭ 2024. Крылов-1

Все шестибуквенные слова, составленные из букв Ф. А, В, О, Р, И, Т записаны в алфавитном порядке и пронумерованы.

Вот начало списка:
1. АААААА
2. АААААВ
3. АААААИ
4. АААААО
5. АААААР
6. АААААТ
7. АААААФ
...

Определите в этом списке количество слов с чётными номерами, которые не начинаются с буквы О и при этом содержат в своей записи ровно две буквы Р.

Решение:

Python


s = list('ФАВОРИТ')
s.sort()

i, count = 0, 0

for a in s:
    for b in s:
        for c in s:
            for d in s:
                for e in s:
                    for f in s:
                        i += 1
                        word = a + b + c + d + e + f

                        if i % 2 == 0 and a != 'О' and word.count('Р') == 2:
                            count += 1

print(count)

Ответ: \(8640\)